Anope Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000880Anope Development (1.7.x series)Languagepublic2008-02-19 11:272008-08-19 21:07
Reporterkein-of@yandex.ru 
Assigned Tomark@anope.org 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOtherOSOtherOS Version
Product VersionSVN (include a /version response in report) 
Target VersionFixed in Version 
Summary0000880: Wrong help for GETKEY or broken syntax for string value returned by GETKEY
DescriptionOriginal help is:
==========================
CHAN_HELP_GETKEY
    Syntax: GETKEY channel
    
    Returns the key of the given channel. This is a command
    mainly intended to be used by bots and/or scripts, so
    the output is in the following way:
    
    KEY <channel> <key>
    
    key is "NO KEY" if no key is set.
==========================

But:

[12:20:57] -ChanServ- Key for channel #helpdesk is sdsd.

P.S. "sdsd" (key value) is BOLD -> that's make it harder for parsing by scripts

Version: Anope-1.7.21 (1387)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2008-02-19 17:10 jobe@anope.org CC => jobe@anope.org
2008-02-19 17:10 jobe@anope.org AssignedTo anope-quality@lists.sourceforge.net => anope-devel@lists.sourceforge.net
2008-02-19 17:10 jobe@anope.org Status UNCONFIRMED => NEW
2008-02-19 17:10 jobe@anope.org Ever Confirmed 0 => 1
2008-08-17 16:29 mark@anope.org CC => mark@anope.org
2008-08-17 16:29 mark@anope.org AssignedTo anope-devel@lists.sourceforge.net => mark@anope.org
2008-08-17 16:29 mark@anope.org Status NEW => ASSIGNED
2008-08-18 00:42 mark@anope.org Status ASSIGNED => RESOLVED
2008-08-18 00:42 mark@anope.org Resolution => FIXED
2008-08-19 21:07 chaz@anope.org Status RESOLVED => CLOSED


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker