View Issue Details

IDProjectCategoryView StatusLast Update
0001746Anope Stable (2.0.x series)Generalpublic2022-01-10 18:17
ReporterMalaGaM Assigned ToSadie  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0001746: Warning CMAKE
Description# cmake -DINSTDIR=/home/anope/ -DDEFUMASK=077 -DCMAKE_BUILD_TYPE=RELEASE ..
CMake Deprecation Warning at CMakeLists.txt:2 (cmake_minimum_required):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at CMakeLists.txt:6 (cmake_policy):
  The OLD behavior for policy CMP0026 will be removed from a future version
  of CMake.

  The cmake-policies(7) manual explains that the OLD behaviors of all
  policies are deprecated and that a policy should be set to OLD only under
  specific short-term circumstances. Projects should be ported to the NEW
  behavior and not rely on setting a policy to OLD.


CMake Deprecation Warning at CMakeLists.txt:9 (cmake_policy):
  The OLD behavior for policy CMP0007 will be removed from a future version
  of CMake.

  The cmake-policies(7) manual explains that the OLD behaviors of all
  policies are deprecated and that a policy should be set to OLD only under
  specific short-term circumstances. Projects should be ported to the NEW
  behavior and not rely on setting a policy to OLD.
Steps To Reproducecompil with cmake version 3.20.3
Additional Information#cmake --version
cmake version 3.20.3

ANOPE_VERSION="2.0.9"
OS ALPINE_VERSION=latest
Tagscmake

Activities

Sadie

2022-01-10 18:16

manager   ~0006879

This is because we need to support old versions of CMake in the v2.0 branch. It is fixed in the v2.1 development brancxh.

allaynawilson

2021-10-23 23:04

reporter   ~0006878

lol

Issue History

Date Modified Username Field Change
2021-07-07 02:54 MalaGaM New Issue
2021-07-07 02:54 MalaGaM Tag Attached: cmake
2021-10-23 23:04 allaynawilson Note Added: 0006878
2022-01-10 18:16 Sadie Note Added: 0006879
2022-01-10 18:17 Sadie Assigned To => Sadie
2022-01-10 18:17 Sadie Status new => resolved
2022-01-10 18:17 Sadie Resolution open => fixed