View Issue Details

IDProjectCategoryView StatusLast Update
0001702Anope Stable (2.0.x series)Generalpublic2017-03-18 21:30
Reporterpegasus Assigned ToAdam  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0001702: NS KeepModes not set upon nick registration even with ns_keepmodes on NS defults
DescriptionSince i've started using Anope v2.x series, i have ns_keepmodes enabled on the NS defaults, on nickserv.config.
Recently i've found that upon nick registration, the keepmodes option is not being set to the registered user.
Steps To ReproduceEnable ns_keepmodes on NS defaults.
Register a new nick.
Do /ns info nick
Check NS options enabled (keepmodes isn't there).
Additional InformationHere's what i have on NS defaults on nickserv.conf:

defaults = "ns_secure ns_private hide_email hide_mask memo_signon memo_receive autoop ns_keepmodes killprotect"


After registering a new nick, i've done /ns info to myself (as shown below, keepmodes isn't present even after being enable on NS defaults)

[01:30] -NickServ-: Registered: Mar 18 00:27:06 2017 WET (2 minutes ago)
[01:30] -NickServ-: Options: Private, Protection, Security, Auto-op, Chanstats
TagsNo tags attached.

Activities

Adam

2017-03-18 21:30

administrator   ~0006838

Fixed in 3545e8e3836df214db4ec8c7b4e57843a1971d37

Adam

2017-03-18 21:18

administrator   ~0006837

This looks like the documentation is wrong, should be ns_keep_modes.

Issue History

Date Modified Username Field Change
2017-03-18 03:08 pegasus New Issue
2017-03-18 21:18 Adam Note Added: 0006837
2017-03-18 21:30 Adam Note Added: 0006838
2017-03-18 21:30 Adam Status new => resolved
2017-03-18 21:30 Adam Resolution open => fixed
2017-03-18 21:30 Adam Assigned To => Adam