View Issue Details

IDProjectCategoryView StatusLast Update
0001692Anope Stable (2.0.x series)Generalpublic2016-12-20 02:05
ReporterAnikwa Assigned ToAdam  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Summary0001692: XMLRPC Call Fails if Channel Topic has Colour.
DescriptionIf a channel topic has mIRC colour codes in it, XMLRPC call fails with the error: "expat reports error code 4"


Psy Shell v0.7.2 (PHP 7.0.8-0ubuntu0.16.04.3 — cli) by Justin Hileman
>>> $anope = new UKBB\Anope;
=> UKBB\Anope {0000880}
>>> $anope->channel('#Lobby');
expat reports error code 4
        description: not well-formed (invalid token)
        line: 34
        column: 17
        byte index: 463
        total bytes: 0

        data beginning 10 before byte index: >[13,9916+] 04,99Welcome to the Lobby on UKBlabberbox! || => null

Whereas without color:

>>> $anope->channel('#Lobby');
=> [
     "bancount" => "0",
     "exceptcount" => "0",
     "invitecount" => "0",
     "name" => "#Lobby",
     "topic" => "[16+] Welcome to the Lobby on UKBlabberbox! || If you need help, please join #help",
     "topicsetter" => "Sketch",
     "topictime" => "1479951703",
     "topicts" => "1479951703",
     "users" => "~@UKBlabberbox %Sketch *@JustifiedkNot ~@Gateway",
   ]
TagsNo tags attached.

Activities

Adam

2016-12-20 02:05

administrator   ~0006820

Reopen if this is still a problem.

Adam

2016-12-11 16:53

administrator   ~0006819

I can't reproduce this locally, it strips the chr(3) from the output as it can't be represented in xml.

Anikwa

2016-11-24 21:45

reporter   ~0006817

One possible fix would be to remove any formatting from the topic before returning it

Issue History

Date Modified Username Field Change
2016-11-24 03:42 Anikwa New Issue
2016-11-24 21:45 Anikwa Note Added: 0006817
2016-12-11 16:53 Adam Note Added: 0006819
2016-12-20 02:05 Adam Note Added: 0006820
2016-12-20 02:05 Adam Status new => closed
2016-12-20 02:05 Adam Assigned To => Adam
2016-12-20 02:05 Adam Resolution open => unable to reproduce