View Issue Details

IDProjectCategoryView StatusLast Update
0001643Anope Stable (2.0.x series)Generalpublic2015-06-30 00:37
ReporterNoMiaus Assigned ToAdam  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0001643: Anope keeps +I mode
DescriptionAnope keeps +I when using NickServ SET KEEPMODES because it doesn't recognise it like a mode for IRC operators only on unreal.cpp.

ModeManager::AddUserMode(new UserMode("HIDEIDLE", 'I'));

I think it should be:

ModeManager::AddUserMode(new UserModeOperOnly("HIDEIDLE", 'I'));

TagsNo tags attached.

Activities

Adam

2015-06-30 00:37

administrator   ~0006744

thanks, fixed in 074f1637508d76e2c21e9d698f265a0b4291f3b0

Issue History

Date Modified Username Field Change
2015-03-27 16:23 NoMiaus New Issue
2015-06-30 00:37 Adam Note Added: 0006744
2015-06-30 00:37 Adam Status new => resolved
2015-06-30 00:37 Adam Resolution open => fixed
2015-06-30 00:37 Adam Assigned To => Adam