Anope Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001599Anope Stable (2.0.x series)[All Projects] Generalpublic2014-05-09 01:432014-05-11 20:52
ReporterPeterB 
Assigned ToAdam 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionunable to reproduce 
Platformx86_64OSUbuntuOS Version12.04
Summary0001599: Registering a channel through ChanServ does not force channel mode +r
DescriptionWhen registering a channel through ChanServ, a notice is received that the registration succeeded, but channel mode +r is not being set on the channel itself.

The "require" setting for the "chanserv" module was set appropriately in my configuration, to the string "r" as its value.

I have attached a patch with a proposed fix.
TagsNo tags attached.
Attached Filesdiff file icon chanserv-require-patch.diff [^] (624 bytes) 2014-05-09 01:43 [Show Content]

- Relationships

-  Notes
(0006645)
Adam (administrator)
2014-05-11 20:52

Reopen if you are able to reproduce without modifications and provide logs. Thanks.
(0006644)
Adam (administrator)
2014-05-09 03:37

This work okay for me without your modification:

[May 08 22:35:24.079283 2014] Debug: Received: :869AAAAAA PRIVMSG 00BAAAAAC :register #adam
[May 08 22:35:24.080125 2014] COMMAND: Adam!Adam@192.168.1.123 used REGISTER on #adam
[May 08 22:35:24.080274 2014] Debug: Sent: :00BAAAAAC NOTICE 869AAAAAA :Channel #adam registered under your account: Adam
[May 08 22:35:24.080391 2014] Debug: Setting correct user modes for Adam on #adam (giving modes)
[May 08 22:35:24.080546 2014] Debug: Setting +q on #adam for Adam
[May 08 22:35:24.083206 2014] Debug: Sent: :00BAAAAAC FMODE #adam 1399602922 +rq 869AAAAAA

The code here: https://github.com/anope/anope/blob/2.0/modules/pseudoclients/chanserv.cpp#L283 [^] is what sets it.

Start services with -support and pastebin everything and then we'll be able to tell what's wrong.
(0006643)
PeterB (reporter)
2014-05-09 01:45

For further reference, we run InspIRCd 2.0.16 as the ircd. This problem occurred with a fresh Anope 2.0 build, from source, with no imported data yet.

- Issue History
Date Modified Username Field Change
2014-05-09 01:43 PeterB New Issue
2014-05-09 01:43 PeterB File Added: chanserv-require-patch.diff
2014-05-09 01:45 PeterB Note Added: 0006643
2014-05-09 03:37 Adam Note Added: 0006644
2014-05-11 20:52 Adam Note Added: 0006645
2014-05-11 20:52 Adam Status new => closed
2014-05-11 20:52 Adam Assigned To => Adam
2014-05-11 20:52 Adam Resolution open => unable to reproduce


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker