Anope Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001585Anope Development (1.9.x series)Nickservpublic2014-04-12 03:222014-05-15 00:19
Reporterwaser 
Assigned ToAdam 
PriorityhighSeveritymajorReproducibilityN/A
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001585: When nick in a group expired, did not change access masks to display nickname.
DescriptionWhen a nick expires in a group, the access mask on channels which that nick had access to do not change to the main display nick.
Steps To Reproduce1-Register a nick (0000001)
2-Group it to another nick (0000002)
3-Give access to nick 0000002 to a channel
4-Let nick 0000002 expire

Result: Channel access is still existing, but as nick 0000002 (which is not registered anymore), it does not change all access masks of nick 0000002 on all channels to nick 0000001
Additional InformationI assume that someone can register nick 0000002 again and gain access to the channels nick 0000002 used to have access to.
TagsNo tags attached.
Attached Files

- Relationships
parent of 0001600resolvedAdam Anope Stable (2.0.x series) Expired account are not removed from channel access list 

-  Notes
(0006648)
Adam (administrator)
2014-05-15 00:18

Fixed in df321a118e7dd44dcd3a389f8ee75e9ff915b55e
(0006617)
Adam (administrator)
2014-04-12 09:22

It sounds to me like you are adding the nick by mask and not by account (eg Adam!*@* and not Adam). This is the intentional behavior.

- Issue History
Date Modified Username Field Change
2014-04-12 03:22 waser New Issue
2014-04-12 09:22 Adam Note Added: 0006617
2014-04-26 22:19 Adam Status new => closed
2014-04-26 22:19 Adam Assigned To => Adam
2014-04-26 22:19 Adam Resolution open => unable to reproduce
2014-05-15 00:18 Adam Note Added: 0006648
2014-05-15 00:18 Adam Status closed => resolved
2014-05-15 00:18 Adam Resolution unable to reproduce => fixed
2014-05-15 00:19 Adam Relationship added parent of 0001600


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker