View Issue Details

IDProjectCategoryView StatusLast Update
0001583Anope Development (1.9.x series)Botservpublic2014-03-15 04:17
ReporterTechman Assigned ToYoerger  
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionsuspended 
PlatformLinuxOSUbuntu Server 
Summary0001583: After latest hs_group sync git update, some BotServ bots in some channels are not getting their configured prefix modes
DescriptionThis is rather weird, but for some reason when some BotServ bots rejoined channels after an /os restart without getting their channel operator status (this is what I configured them to get).
Steps To Reproduce1) Update to git commit ca6b3723a9 ( http://git.io/97Ebsg )
2) Restart services
3) For some reason botserv bots in some channels didn't get their channel op status
Additional InformationBesides not getting their +o, the bots function just fine. They can still kick, ban, etc and give modes like normal. They are not opped though. I restarted services twice and this happened, so I am not sure if this is solid or just randomly happening.

Tested on InspIRCd 2.0.15 (with m_servprotect loaded)

https://www.irccloud.com/pastebin/D4DH5xgv

Paste will expire in a few days.
TagsNo tags attached.

Activities

Adam

2014-03-15 04:17

administrator   ~0006616

Fixed in ef9729fb02dd3e44f59b447b567cdeb450690344

Yoerger

2014-03-14 08:41

developer   ~0006615

I'll just suspend it for now. Techman, The last thing we need is banter on the bug tracker. (Alliteration intended).

Techman

2014-03-14 04:03

reporter   ~0006614

1) I will not flatly link debug logs because of the nature of them being very sensitive, even with user hosts and IPs stripped out. Doesn't matter anyways, because reversing that commit worked.

2) If you really think I made all of this up, please go ask ANY of my users about the hell I had trying to figure what the hell happened. The very reason why I was a bit impatient was because my users were freaking out about "Why is ChanServ not op???". In the mean time, I manually opped bots in affected channels myself.

You are welcome to close this issue now, because I don't see a close button anywhere. That commit you pointed to above is the one that broke it :).

Glad to hear that a "final" is coming out soon. Time for Anope to shine.

Adam

2014-03-13 00:12

administrator   ~0006613

Since you seem incapable of providing logs this really is not a priority for me at the moment. No you may not "PM me them", put them here like normal people do.

Robby picked out a commit he thought was related, which is 59693624250eb411265844e42322c05d1825acf1.

I am still aware this bug exists, you do not have to "To Adam" me, it just makes you look impatient and childish. This is one of the reasons you remain banned most everywhere.

I already asked you once for debug logs of this bug, which you have yet to provide, so it seems I am actually waiting for you.

I am also aware of your history of reporting "issues" (most of which are not real) and then flatly refuse to provide any sort of debug information when asked, simply stating it is wrong. This is why this low priority to me, as I feel I should not have to waste my time trying to reproduce a problem because you are too stubborn to provide logs. I'll try and get it in this week before the final.

Yoerger

2014-03-12 23:48

developer   ~0006612

..

Techman

2014-03-12 23:12

reporter   ~0006611

Okay, wanted to add some notes to this issue:

1) I downloaded the official rc4 build on my local testnet and ported a fresh updated copy of my services db to it and started it. Results: BotServ bots were opping themselves like normal in the affected channels. This confirms that some update AFTER the rc4 build broke it.

2) The channels affected seem to be "old" ones -- ones that were imported from my old Anope 1.8 setup. Newly registered channels are not affected by this bug. While I don't think this is relevant, I am just dropping things I have noticed.

----

I honestly think something with how channel modes are set is the root of this issue. I have always-lower-ts turned on if this helps. I would point fingers specifically at commits that changed chanserv or how channel modes are handled.

To Adam: Still waiting for your reply.

Techman

2014-03-11 12:10

reporter   ~0006609

Is there a way I can PM you logs?

I ran services with -support before, but there was so many lines that it exceeded my set scrollback limit. Does running services from start in debug mode and collecting the log data sufficient enough?

I also did strip out user hosts and IP addresses and replaced them with <host> and <IP>, respectively.

Adam

2014-03-11 04:22

administrator   ~0006608

Run with ./services -support and pastebin evreything when reproducing this behavior

Issue History

Date Modified Username Field Change
2014-03-11 00:52 Techman New Issue
2014-03-11 04:22 Adam Note Added: 0006608
2014-03-11 12:10 Techman Note Added: 0006609
2014-03-12 23:12 Techman Note Added: 0006611
2014-03-12 23:48 Yoerger Note Added: 0006612
2014-03-13 00:12 Adam Note Added: 0006613
2014-03-14 04:03 Techman Note Added: 0006614
2014-03-14 08:41 Yoerger Note Added: 0006615
2014-03-14 08:41 Yoerger Status new => resolved
2014-03-14 08:41 Yoerger Resolution open => suspended
2014-03-14 08:41 Yoerger Assigned To => Yoerger
2014-03-15 04:17 Adam Note Added: 0006616