View Issue Details

IDProjectCategoryView StatusLast Update
0001581Anope Development (1.9.x series)Nickservpublic2014-03-10 13:33
ReporterTechman Assigned ToAdam  
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Summary0001581: NickServ's noticeunregister still sends the message even after a successful SASL auth
Description(read title)
Steps To Reproduce1) Register a nick (make sure noticeunregister is on ofc)
2) Reconnect and identify to your account
3) Notice you don't get the notification because you logged in via SASL and you owned the nick and got +r
4) Reconnect as a different nick and auth as yourself
5) Get logged in
6) See the unregistered notification
Additional InformationAlthough technically when you use SASL to identify to a nick you don't own, I don't think this notice is necessary because a user would be logged in at this point....
TagsNo tags attached.

Activities

Adam

2014-03-10 13:33

administrator   ~0006607

Fixed in 860deb14ce6b6ccda12d8d842004c8b93d843711

Issue History

Date Modified Username Field Change
2014-03-05 04:56 Techman New Issue
2014-03-10 13:33 Adam Note Added: 0006607
2014-03-10 13:33 Adam Status new => resolved
2014-03-10 13:33 Adam Resolution open => fixed
2014-03-10 13:33 Adam Assigned To => Adam