View Issue Details

IDProjectCategoryView StatusLast Update
0001573Anope Development (1.9.x series)Operservpublic2014-02-17 20:54
ReporterCMF2000 Assigned ToAdam  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0001573: OperServ (os_session) doesn't find sessions if session_(ipv4|ipv6)_cidr is set in config
DescriptionSessions aren't found when session_ipv4_cidr < 32 or session_ipv6_cidr < 128 is set.
The old sessions won't be deleted and you get killed by operserv because of reaching the sessionlimit.
Steps To Reproduce1. set session_ipv4_cidr = 24
2. connect to your ircd
3. /msg operserv session view [your ip] <= it says not found
4. reconnect to ircd
5. /msg operserv session list 2 <= the old session is still there


It's also related to IPv6 clients: step 1. session_ipv6_cidr = 64
Additional InformationMaybe there is something wrong with cidr::hash in sockets.cpp that sessions aren't found in the SessionMap (unordered_map)?
TagsNo tags attached.

Activities

Adam

2014-02-17 20:54

administrator   ~0006594

Good find, fixed in 707494481046d330ee5b2eb641b67cb4fc96f6ca

Issue History

Date Modified Username Field Change
2014-02-17 16:44 CMF2000 New Issue
2014-02-17 20:54 Adam Note Added: 0006594
2014-02-17 20:54 Adam Status new => resolved
2014-02-17 20:54 Adam Resolution open => fixed
2014-02-17 20:54 Adam Assigned To => Adam