Anope Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001533Anope Development (1.9.x series)Nickservpublic2013-06-25 20:032013-07-21 05:38
ReporterObiWan 
Assigned ToAdam 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001533: ldap not being searched on identify
DescriptionI've just noticed today that the ldap module doesn't seem to be queried anymore when an "identify" to Nickserv is issued.

I can't see any request inside of my debug log and new users can't authenticate even if they are definitively there.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0006501)
Adam (administrator)
2013-07-21 05:38

fixed in e11abdc4f00b19feae7830d4de6098e282e7eb39
(0006490)
DukePyrolator (administrator)
2013-06-29 19:13

confirmed, I can reproduce it.

m_ldap says it binds to the ldap server, but there is no outgoing tcp connection.
m_ldap_authentication aborts in OnCheckAuthentication() on the "this->ldap" check.
(0006489)
ObiWan (reporter)
2013-06-29 17:34

Do you have any idea what the problem could be?
(0006482)
ObiWan (reporter)
2013-06-25 21:06

I've already tried to restart several times however it didn't make a difference. That was my first idea that the module just crashed for some reason.


Version:
commit 7d0e0633009d38c0daff4969cf0928581a35bcaf
Author: DukePyrolator <DukePyrolator@anope.org>
Date: Sat Jun 22 17:06:48 2013 +0200
(0006481)
chaz (administrator)
2013-06-25 20:13

Hi,

I've seen this happen on 1.9.x where for no reason it stops working until the module is unloaded (which used to crash but that's fixed) and re-loaded.

Have you tried that, or restarting anope?

Which version exactly are you using please?

Thanks,

- Issue History
Date Modified Username Field Change
2013-06-25 20:03 ObiWan New Issue
2013-06-25 20:13 chaz Note Added: 0006481
2013-06-25 21:06 ObiWan Note Added: 0006482
2013-06-29 17:34 ObiWan Note Added: 0006489
2013-06-29 19:13 DukePyrolator Note Added: 0006490
2013-07-21 05:38 Adam Note Added: 0006501
2013-07-21 05:38 Adam Status new => resolved
2013-07-21 05:38 Adam Resolution open => fixed
2013-07-21 05:38 Adam Assigned To => Adam


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker