View Issue Details

IDProjectCategoryView StatusLast Update
0001527Anope Stable (1.8.x series)Modulespublic2013-06-05 18:11
Reportermax Assigned ToViper  
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindows 
Summary0001527: Lock option "DisableRaw" does not work
DescriptionIn the configuration file services.conf option "DisableRaw" uncommented.
When the Root Service run the commands "/OperServ ModLoad os_raw", returns the result:
"-OperServ-Module os_raw loaded".
At the same time, the log-channel receive the following message:
<Global> [Os_raw] Unloading because DisableRaw is enabled
<Global> Module loading status: 0 (Module, Okay - No Error).

There is a question, why os_raw module is still loaded, despite the lock?
TagsNo tags attached.

Activities

Viper

2013-06-05 16:52

manager   ~0006464

Fixed in f1c3f0d820caedfd7667c09bd06f60b9c23283d9.

Viper

2013-06-05 09:23

manager   ~0006463

This bug is much more severe then it would seem at first glance.. check following output:
 «Global» Trying to load module [svc_test]
 «Global» aborting load..
 «Global» Module loading status: 0 (Module, Okay - No Error)

All modules that issue a MOD_STOP in AnopeInit because the conditions for their load are not fulfilled and issue a MOD_STOP to abort loading are actually loaded.. some of these modules may not perform any further sanity checks in their code and assume that all modes or conditions they depend upon are fulfilled.. this could lead to dangerous conditions, possibly causing crashes or invalid commands being send to the IRCd. If not by the core modules, probably by 3rd party ones - I'm pretty sure some of my modules will be affected..

max

2013-06-04 20:45

reporter   ~0006462

Thank's.

chaz

2013-06-04 20:22

administrator   ~0006461

Thanks, I've just confirmed this on 1.8.8 with the same IRCd.

Marking the bug as confirmed.

max

2013-06-04 20:20

reporter   ~0006460

I use UnrealIRCd 3.2.10.1 + Anope 1.8.8

chaz

2013-06-04 20:16

administrator   ~0006459

Thanks, that's cool I'll try and reproduce it in a moment.

Can you confirm which version of Anope you're using, together with ircd+version?

Thanks.

max

2013-06-04 20:10

reporter   ~0006458

Yes, that's right.
Despite the fact that there is a message that the module can not be loaded (<Global> [Os_raw] Unloading because DisableRaw is enabled), the next message indicates that the module is loaded successfully (<Global> Module loading status: 0 (Module, Okay - No Error)).
And the command "/OperServ Raw" executed, despite the lockout.

chaz

2013-06-04 19:25

administrator   ~0006457

Hello,

I do not understand what the issue is here.

Having DisableRaw uncommented implies that you want raw to be disabled.

Attempting to load the module os_raw passes because you're asking it to load, it is then unloaded again because of DisableRaw being in place.

This is expected behaviour.

Or are you saying that despite the message from global saying "unloading because DisableRaw is enabled" that it infact does not unload?

Issue History

Date Modified Username Field Change
2013-06-04 18:27 max New Issue
2013-06-04 19:25 chaz Note Added: 0006457
2013-06-04 20:10 max Note Added: 0006458
2013-06-04 20:16 chaz Note Added: 0006459
2013-06-04 20:20 max Note Added: 0006460
2013-06-04 20:22 chaz Note Added: 0006461
2013-06-04 20:22 chaz Status new => confirmed
2013-06-04 20:45 max Note Added: 0006462
2013-06-05 09:12 Viper Priority normal => urgent
2013-06-05 09:12 Viper Severity minor => major
2013-06-05 09:12 Viper Category OperServ => Modules
2013-06-05 09:23 Viper Note Added: 0006463
2013-06-05 16:52 Viper Note Added: 0006464
2013-06-05 16:52 Viper Status confirmed => resolved
2013-06-05 16:52 Viper Resolution open => fixed
2013-06-05 16:52 Viper Assigned To => Viper