Anope Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001478Anope Development (1.9.x series)Botservpublic2013-02-11 00:562013-02-16 07:43
Reporterivan 
Assigned ToAdam 
PrioritynormalSeverityfeatureReproducibilityalways
StatusresolvedResolutionfixed 
PlatformLinuxOSDebianOS Version6 x64
Product Version 
Target VersionFixed in Version 
Summary0001478: Botservs don't get +ao modes on channels that already have Service Bots
DescriptionBotservs don't get +ao modes on channels that already have Service Bots
Steps To ReproduceAssuming OtherBotserv is a botserv created and assign to a certain channel and Global is a Global Message service bot

* Disconnected: OtherBotserv (services@vircio.org) (Shutting down)
* Disconnected: ~Global (services@vircio.org) (Shutting down)
* Joined: Global (services@vircio.org)
* Joined: OtherBotserv (services@vircio.org)
* OtherBotserv sets mode: +q Global

At this time, OtherBotserv works fine giving modes to othes bots or users, but don't get +ao modes.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0006370)
Adam (administrator)
2013-02-16 07:43

fixed in 7be23b7e374d343f60c4b698365719a3aba7f8f2
(0006369)
cirinho (reporter)
2013-02-16 02:41

Anope-1.9.8-may-cause-insanity services.vircio.org :InspIRCd 2.0 - (enc_md5) -- build 0000002, compiled 21:34:08 Feb 15 2013, flags D

last commit from git
(0006363)
cronus (developer)
2013-02-12 00:11

I tried it two different ways. Giving the services config bot ~ and without. here are the results

[16:05:38] [RAW]: os restart
[16:05:38] <Global> [>> $hub.kratos.nite-serv.com] Services are restarting, they will be back shortly - please be good while we're gone
[16:05:38] Global [services@services.nite-serv.com] has quit IRC: Shutting down
[16:05:38] Keeper [Channel@Guard.Kamuix] has quit IRC: Shutting down
[16:05:39] Global [services@services.nite-serv.com] has joined #hangout
[16:05:39] Keeper [Channel@Guard.Kamuix] has joined #hangout
[16:05:39] <Global> [>> $hub.kratos.nite-serv.com] Services are now back online - have a nice day
[16:05:39] Keeper [Channel@Guard.Kamuix] has set mode +oa Keeper Keeper
[16:06:05] [RAW]: os restart
[16:06:05] <Global> [>> $hub.kratos.nite-serv.com] Services are restarting, they will be back shortly - please be good while we're gone
[16:06:05] Global [services@services.nite-serv.com] has quit IRC: Shutting down
[16:06:05] Keeper [Channel@Guard.Kamuix] has quit IRC: Shutting down
[16:06:06] Global [services@services.nite-serv.com] has joined #hangout
[16:06:06] Keeper [Channel@Guard.Kamuix] has joined #hangout
[16:06:06] <Global> [>> $hub.kratos.nite-serv.com] Services are now back online - have a nice day
[16:06:06] Keeper [Channel@Guard.Kamuix] has set mode +aoa Global Keeper Keeper
[16:06:06] Keeper [Channel@Guard.Kamuix] has set mode +aoa Global Keeper Keeper

As you see it works fine for me, I am using git from a week or so ago.

Please post the output of /version services.*

your config settings for Global Bot.

And what IRCd
(0006360)
Adam (administrator)
2013-02-11 05:01

Not much, though it should always +ao (or whatever you set in the config) the bot assigned by BotServ.
(0006359)
ivan (reporter)
2013-02-11 03:26
edited on: 2013-02-11 03:32

I don't know what is wrong with my english.
I know we can't have more than one botserv bot in a channel at same time.
The thing is, Global is a Service bot configured on .conf files.
OtherBotserv bot is a regular botserv.

Anope doesn't make difference between them?

(0006358)
Adam (administrator)
2013-02-11 02:32

Do you know anyone who speaks English who can explain this? You can't have more than one botserv bot in a channel at one time.

- Issue History
Date Modified Username Field Change
2013-02-11 00:56 ivan New Issue
2013-02-11 02:32 Adam Note Added: 0006358
2013-02-11 03:26 ivan Note Added: 0006359
2013-02-11 03:32 ivan Note Edited: 0006359 View Revisions
2013-02-11 05:01 Adam Note Added: 0006360
2013-02-12 00:11 cronus Note Added: 0006363
2013-02-16 02:41 cirinho Note Added: 0006369
2013-02-16 07:43 Adam Note Added: 0006370
2013-02-16 07:43 Adam Status new => resolved
2013-02-16 07:43 Adam Resolution open => fixed
2013-02-16 07:43 Adam Assigned To => Adam


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker