View Issue Details

IDProjectCategoryView StatusLast Update
0001372Anope Development (1.9.x series)Nickservpublic2012-01-13 22:42
ReporterNita Assigned ToAdam  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux x64OSDebian 
Summary0001372: User regged, NS AutoOp OFF, Connect, Join channel without identify. Gets OP from server
DescriptionSettings:
- Test user registered.
- Test user has channel op status in #Nita
- /msg NickServ set AUTOOP off (AUTOOP turned off)

Scenario:
- Start services
- Connect to the server with user TEST but do not identify
- Join a channel where you have OP (#Nita)
- Server gives me OP status

LOG: http://pastebin.com/T1z7gbSe
Additional InformationLOG: http://pastebin.com/T1z7gbSe
TagsNo tags attached.

Activities

Adam

2012-01-13 22:42

administrator   ~0006061

Fixed in c462a69b7da4570ed07e627d81dbb80e012c7788

Nita

2012-01-13 13:31

reporter   ~0006060

I am using flag system and this error occurs only when Anope starting up and log in at the first time. It does not happen again when I /cycle #Nita or reconnect to the server.

/msg ChanServ help flags
- ChanServ: The available flags are:
- ChanServ: 1 - Allowed to (de)voice users
- ChanServ: 2 - Allowed to (de)halfop users
- ChanServ: 3 - Allowed to (de)op users
- ChanServ: 4 - Allowed to (de)protect users
- ChanServ: 5 - Allowed to (de)owner users
- ChanServ: A - Automatic mode +a
- ChanServ: a - Allowed to (de)protect him/herself
- ChanServ: B - Allowed to modify channel badwords list
- ChanServ: b - Allowed to use ban users
- ChanServ: c - Allowed to modify the access list
- ChanServ: d - Allowed to assign/unassign a bot
- ChanServ: f - Allowed to use fantasy commands
- ChanServ: F - Allowed to issue commands restricted to channel founders
- ChanServ: G - Allowed to use GETKEY command
- ChanServ: g - Greet message displayed on join
- ChanServ: H - Automatic mode +h
- ChanServ: h - Allowed to (de)halfop him/herself
- ChanServ: I - Allowed to get full INFO output
- ChanServ: i - Allowed to use the INVITE command
- ChanServ: K - Allowed to use the AKICK command
- ChanServ: k - Allowed to use the KICK command
- ChanServ: l - Allowed to view the access list
- ChanServ: M - Allowed to read channel memos
- ChanServ: m - Allowed to use the MODE command
- ChanServ: n - Prevents users being kicked by Services
- ChanServ: N - No signed kick when SIGNKICK LEVEL is used
- ChanServ: O - Automatic channel operator status
- ChanServ: o - Allowed to (de)op him/herself
- ChanServ: Q - Automatic mode +q
- ChanServ: q - Allowed to (de)owner him/herself
- ChanServ: s - Allowed to use SAY and ACT commands
- ChanServ: S - Allowed to set channel settings
- ChanServ: t - Allowed to change channel topics
- ChanServ: u - Allowed to unban users
- ChanServ: V - Automatic mode +v
- ChanServ: v - Allowed to (de)voice him/herself

/msg ChanServ FLAGS #Nita list
- ChanServ: Flags list for #Nita
- ChanServ: Number Mask Flags Creator Created
- ChanServ: 1 Test 1234ABGHIKMNOVabcfghiklnotuv Nita Jan 10 23:34:28 2012 UTC
- ChanServ: End of access list.

Robby

2012-01-13 12:45

manager   ~0006059

Can't reproduce this.
Please show the output of this command:
/msg ChanServ ACCESS #Nita LIST

Issue History

Date Modified Username Field Change
2012-01-12 20:44 Nita New Issue
2012-01-13 12:45 Robby Note Added: 0006059
2012-01-13 13:31 Nita Note Added: 0006060
2012-01-13 22:42 Adam Note Added: 0006061
2012-01-13 22:42 Adam Status new => resolved
2012-01-13 22:42 Adam Resolution open => fixed
2012-01-13 22:42 Adam Assigned To => Adam