View Issue Details

IDProjectCategoryView StatusLast Update
0001354Anope Development (1.9.x series)Operservpublic2011-11-03 08:32
ReporterRobby Assigned ToAdam  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux, i686OSFedora 
Summary0001354: [anope-1.9-230b3bc] disabling +a/+q prefixes on the ircd gives problems in *serv.conf service:channels setting
DescriptionI have disabled the prefixes & and ~ in the ircd but the +a and +q modes still work. Now the problem is that in the service blocks the following setting doesn't work as expected anymore: channels = "&@#Services"

It only seems to parse the @ now and sets itself +o only and not +ao.
Steps To ReproduceDisable prefixes in InspIRCd by setting aprefix and qprefix to "".
Restart services, and you will notice they only set +o instead of +ao.
Additional InformationInspIRCd 2.0.5
Anope 1.9-git 230b3bc
TagsNo tags attached.

Activities

Adam

2011-11-03 08:32

administrator   ~0006000

Fixed in ca33ac608d77229f651aea6566aee9847b9aac2e

Issue History

Date Modified Username Field Change
2011-11-02 16:03 Robby New Issue
2011-11-03 08:32 Adam Note Added: 0006000
2011-11-03 08:32 Adam Status new => resolved
2011-11-03 08:32 Adam Resolution open => fixed
2011-11-03 08:32 Adam Assigned To => Adam