View Issue Details

IDProjectCategoryView StatusLast Update
0001351Anope Development (1.9.x series)Nickservpublic2011-10-28 00:12
ReporterNita Assigned ToAdam  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSLinux 
Summary0001351: [Anope 1.9-GIT]: AUTOOP OFF not working
Description/msg ChanServ FLAGS #Test MODIFY Test +aAoO
/msg NickServ SASET AUTOOP Test OFF

When "Test" identifies him/herself with: /msg NickServ IDENTIFY mypassword:
Test gets +ao modes in #Test automatically when AUTOOP is currently turned off
Steps To Reproduce/msg ChanServ FLAGS #Test MODIFY Test +aAoO
/msg NickServ SASET AUTOOP Test OFF

/msg NickServ IDENTIFY mypassword

/* Test gets OP when AUTOOP turned off */
Additional InformationInspircd 2.0
TagsNo tags attached.

Activities

Adam

2011-10-28 00:12

administrator   ~0005986

Ok thanks, fixed in d9333e02fa455303b7236b6f002625f2cad4ed19

Nita

2011-10-27 22:19

reporter   ~0005985

http://pastebin.com/GwekcJqc

First part shows that AUTOOP is not enabled in anope.db (see "DATA flags" row)
After that I started services with --debug. You can see "Nrisimha" user which is actually a BotServ bot. Part of the debug:

CHANNEL: Anita!~Anita@0::1 join #Nita
Debug: Setting correct user modes for Anita on #Nita (giving modes)
Debug: Setting +a on #Nita for Anita
Debug: Setting correct user modes for Anita on #Nita (not giving modes)
Debug: Setting +o on #Nita for Anita
Debug: Setting correct user modes for Anita on #Nita (not giving modes)
CHANNEL: Nrisimha!services@services.irc.nita.cc join #Nita
Debug: Sent: :002 FJOIN #Nita 1319401784 +ntG :,002AAAAAH
Debug: Setting +a on #Nita for Nrisimha
Debug: Setting +o on #Nita for Nrisimha
Debug: Sent: :002AAAAAH FMODE #Nita 1319401784 +aoao Anita Anita Nrisimha Nrisimha

After that I have +ao set and AUTOOP is OFF in anope.db.
It seems that this is a problem when I am STARTING/RESTARTING services.
If services are running, I can logoff and reident myself, and everything works perfectly. So this happens only once, when I start services.

Adam

2011-10-27 20:46

administrator   ~0005984

I'm unable to reproduce, can we get debug logs of this?

Issue History

Date Modified Username Field Change
2011-10-27 14:19 Nita New Issue
2011-10-27 20:46 Adam Note Added: 0005984
2011-10-27 20:46 Adam Assigned To => Adam
2011-10-27 20:46 Adam Status new => feedback
2011-10-27 22:19 Nita Note Added: 0005985
2011-10-27 22:19 Nita Status feedback => assigned
2011-10-28 00:12 Adam Note Added: 0005986
2011-10-28 00:12 Adam Status assigned => resolved
2011-10-28 00:12 Adam Resolution open => fixed