View Issue Details

IDProjectCategoryView StatusLast Update
0001343Anope Development (1.9.x series)Nickservpublic2011-10-22 21:51
Reporterhardc0re Assigned ToAdam  
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0001343: can't recover/release nick from nick enforcer
Descriptioninspircd20 protocol and anope 1.9.5. when enforcer holds a nick you cant' recover/release it. i 1st use /ns recover nick pass and i get:
-NickServ- User claiming your nick has been killed.
-NickServ- /msg NickServ RELEASE lolek to get it back before 1 minute timeout.
i use after that /ns release nick pass and nothing.
TagsNo tags attached.

Activities

Adam

2011-10-22 21:51

administrator   ~0005978

Fixed in 3e2ac3640d186004798269e6ca89938cb1da6f73

Adam

2011-10-22 00:07

administrator   ~0005977

It looks like you're recovering the enforcer. You should be using release there, I will change it to not allow recovering enforcers though.

hardc0re

2011-10-21 10:33

reporter   ~0005974

http://pastebin.com/DbPm28dh this is from debug.
i also noticed if my nick is in enforcer and i first use /ns release, it releases it fine. maybe i'm wrong with something here

Adam

2011-10-20 23:02

administrator   ~0005973

I am unable to reproduce this, can you get debug logs of it?

Issue History

Date Modified Username Field Change
2011-10-20 11:06 hardc0re New Issue
2011-10-20 23:02 Adam Note Added: 0005973
2011-10-21 10:33 hardc0re Note Added: 0005974
2011-10-22 00:07 Adam Note Added: 0005977
2011-10-22 00:07 Adam Status new => acknowledged
2011-10-22 21:51 Adam Note Added: 0005978
2011-10-22 21:51 Adam Status acknowledged => resolved
2011-10-22 21:51 Adam Resolution open => fixed
2011-10-22 21:51 Adam Assigned To => Adam