View Issue Details

IDProjectCategoryView StatusLast Update
0001296Anope Development (1.9.x series)Nickservpublic2011-07-31 03:10
ReporterRobby Assigned ToAdam  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinux, i686OSFedora 
Summary0001296: NickServ NOEXPIRE lost on start/restart
DescriptionNickname noexpire settings lost on start/restart.

I first tried this with a database converted with ./db-convert and then with a fresh/new database, resulting in always the same problem/bug.

Anope version: 1.9.4
Steps To Reproduce<Robby> REGISTER <password> <email>
-NickServ- Nickname Robby registered.
-NickServ- Your password is <password> - remember this for later use.
<Robby> SASET Robby NOEXPIRE ON
-NickServ- Nick Robby will not expire.
<Robby> INFO Robby ALL
-NickServ- <...>
-NickServ- This nickname will not expire.
/msg OperServ RESTART -or- /msg OperServ SHUTDOWN (and start again via shell)
<Robby> INFO Robby ALL
-NickServ- <...>
-NickServ- Expires on: Oct 30 02:23:49 2011 CET (90 days, 23 hours, 59 minutes from now)
TagsNo tags attached.

Relationships

duplicate of 0001280 resolvedAdam 1.9.5 current: "/msg NickServ SASET USER NOEXPIRE ON" does not write MD FLAG NOEXPIRE to anope.db 

Activities

Adam

2011-07-31 03:10

administrator   ~0005887

Dupe of 0001280

Issue History

Date Modified Username Field Change
2011-07-31 02:34 Robby New Issue
2011-07-31 03:09 Adam Relationship added duplicate of 0001280
2011-07-31 03:10 Adam Note Added: 0005887
2011-07-31 03:10 Adam Status new => closed
2011-07-31 03:10 Adam Assigned To => Adam
2011-07-31 03:10 Adam Resolution open => duplicate