Anope Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001248Anope Stable (1.8.x series)ChanServpublic2011-02-22 21:502011-02-22 22:42
ReporterSaKa 
Assigned ToLEthaLity 
PrioritynormalSeveritytextReproducibilityalways
StatusresolvedResolutionfixed 
PlatformWindowsOSVistaOS Version32bits
Product Version 
Target VersionFixed in Version 
Summary0001248: Reading (null) where supposed to read Nickserv
DescriptionWhen hitting the command /chanserv help set secure, ChanServ answers a (null) instead of NickServ (second %S).
It must be caused by :

    c = createCommand("SET SECURE", NULL, NULL, CHAN_HELP_SET_SECURE, -1,
                      -1, -1, -1);
    c->help_param1 = s_NickServ;

No second parameter is defined.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005755)
LEthaLity (manager)
2011-02-22 22:42

fixed in commit a4c81c72c12a8ab73649c9fbf4987e6cbe3e7c97, thanks
(0005754)
SaKa (reporter)
2011-02-22 22:32

In fr.l, two %s are used instead of one %S and one %s [CHAN_HELP_SET_SECURE].
(0005753)
LEthaLity (manager)
2011-02-22 22:25

bug applies to the french language file
(0005751)
LEthaLity (manager)
2011-02-22 21:53

What version of 1.8 is this? Cant reproduce it in 1.8.5:
Anope-1.8.5-git (3053) services.lethality.me.uk :InspIRCd 2.0 - QM (enc_sha1) -- build 0000001, compiled Jan 7 2011 21:37:07

-[19:50:58]- -ChanServ- Syntax: SET channel SECURE {ON | OFF}
-[19:50:58]- -ChanServ-
-[19:50:58]- -ChanServ- Enables or disables ChanServ's security features for a
-[19:50:58]- -ChanServ- channel. When SECURE is set, only users who have
-[19:50:58]- -ChanServ- registered their nicknames with NickServ and IDENTIFY'd
-[19:50:58]- -ChanServ- with their password will be given access to the channel
-[19:50:58]- -ChanServ- as controlled by the access list.

- Issue History
Date Modified Username Field Change
2011-02-22 21:50 SaKa New Issue
2011-02-22 21:53 LEthaLity Note Added: 0005751
2011-02-22 22:13 LEthaLity Note Added: 0005752
2011-02-22 22:13 LEthaLity Status new => closed
2011-02-22 22:13 LEthaLity Assigned To => LEthaLity
2011-02-22 22:13 LEthaLity Resolution open => no change required
2011-02-22 22:22 LEthaLity Note Deleted: 0005752
2011-02-22 22:25 LEthaLity Note Added: 0005753
2011-02-22 22:25 LEthaLity Status closed => feedback
2011-02-22 22:25 LEthaLity Resolution no change required => reopened
2011-02-22 22:32 SaKa Note Added: 0005754
2011-02-22 22:32 SaKa Status feedback => assigned
2011-02-22 22:42 LEthaLity Note Added: 0005755
2011-02-22 22:42 LEthaLity Status assigned => resolved
2011-02-22 22:42 LEthaLity Resolution reopened => fixed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker