Anope Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001236Anope Stable (1.8.x series)NickServpublic2011-01-25 18:272011-05-02 19:20
ReporterAlex 
Assigned ToAdam 
PriorityhighSeveritycrashReproducibilityalways
StatusresolvedResolutionunable to reproduce 
Platformx86_64 Intel DarwinOSMac OS XOS Version10.6.6
Product Version 
Target VersionFixed in Version 
Summary0001236: Anope crashes on second Nick Regristration / Identify
DescriptionHere is a full log of what happens:
http://pastebin.com/C5A2kWVH [^]
Steps To Reproduce/nick First
/msg NickServ REGISTER somepwd mail@host.tld
(Wait 30 seconds)
/nick Second
/msg NickServ REGISTER somepwd mail@host.tld

=

PANIC! + SQUIT
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005822)
Adam (administrator)
2011-05-02 19:20

Fixed in 6ebbec79ea3787bacd46ebd1ae7964c64f6386cc
(0005821)
chaz (administrator)
2011-04-29 14:09

This is being progressed.
(0005804)
Adam (administrator)
2011-04-27 04:28

It should be noted its been reported compiling enc_md5 without optimization works ok.
(0005803)
chaz (administrator)
2011-04-23 20:05

Changed my mind on this, will attempt to find some hardware.
(0005800)
chaz (administrator)
2011-04-23 08:32

Closing since we have no access to necessary hardware.

If someone wishes to donate hardware, reopen the bug.
(0005786)
Adam (administrator)
2011-04-06 21:34

I think the only way we could look into getting this fixed is if one of the developers was given access to a Mac as we have none. Currently we can't do much.
(0005784)
DanClarkePro (reporter)
2011-04-06 13:01

Can reproduce on 10.6.7, link to my gdb, sorry if too long. http://mby.me/log.txt [^]
(0005745)
alexbarton (reporter)
2011-02-13 16:33
edited on: 2011-02-13 16:35

I can reproduce this bug on Mac OS X 10.6.6.
gdb backtrace (http://pastebin.anope.org/index.php?page=viewpaste&id=55a7a9d9b6 [^]):

Starting program: /opt/anope/services -nofork -debug

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x00007fffd503fb70
0x00007fff884b455b in CC_MD5_Final ()

(gdb) bt
#0 0x00007fff884b455b in CC_MD5_Final ()
0000001 0x00000001003ab7c1 in md5_encrypt (src=0x7fff5fbfe496 "testtest", len=8, dest=0x7fff5fbfdbe0 "", size=1024) at enc_md5.c:348
0000002 0x00000001003ab900 in md5_check_password (plaintext=0x7fff5fbfe496 "testtest", password=0x1005f7688 "C/m2\a#9\005´óÍxÂ@Û\022") at enc_md5.c:383
0000003 0x000000010001e6ab in enc_check_password (plaintext=0x7fff5fbfe496 "testtest", password=0x1005f7688 "C/m2\a#9\005´óÍxÂ@Û\022") at encrypt.c:98
0000004 0x00000001003bf556 in do_identify (u=0x1005f7280) at ns_identify.c:98
0000005 0x000000010001a134 in do_run_cmd (service=0x1004007f0 "NickServ", u=0x1005f7280, c=0x1005301b0, cmd=0x7fff5fbfe493 "id") at commands.c:102
0000006 0x000000010001a027 in mod_run_cmd (service=0x1004007f0 "NickServ", u=0x1005f7280, cmdTable=0x1000aaee0, cmd=0x7fff5fbfe493 "id") at commands.c:71
0000007 0x000000010003979d in nickserv (u=0x1005f7280, buf=0x7fff5fbfe493 "id") at nickserv.c:260
0000008 0x000000010002d2f0 in m_privmsg (source=0x1005f7290 "DukeP2", receiver=0x1005ed960 "NickServ", msg=0x7fff5fbfe493 "id") at messages.c:208
0000009 0x0000000100394d9e in anope_event_privmsg (source=0x7fff5fbff4c0 "971AAAAAA", ac=2, av=0x1005f7420) at inspircd20.c:1868
0000010 0x0000000100045bde in process () at process.c:398
0000011 0x000000010002b454 in main (ac=3, av=0x7fff5fbff5c0, envp=0x7fff5fbff5e0) at main.c:667

(gdb) bt full
#0 0x00007fff884b455b in CC_MD5_Final ()
No symbol table info available.
0000001 0x00000001003ab7c1 in md5_encrypt (src=0x7fff5fbfe496 "testtest", len=8, dest=0x7fff5fbfdbe0 "", size=1024) at enc_md5.c:348
    context = {
  state = {1732584193, 4023233417, 2562383102, 271733878},
  count = {64, 0},
  buffer = "testtestukePyrolator@p57ABF4BE.dip.t-dialin.net logged oNickServ"
}
    tmp = '\0' <repeats 32 times>, ""
0000002 0x00000001003ab900 in md5_check_password (plaintext=0x7fff5fbfe496 "testtest", password=0x1005f7688 "C/m2\a#9\005´óÍxÂ@Û\022") at enc_md5.c:383
    buf = '\0' <repeats 24 times>, "\005œUM\000\000\000\000ß´™2", '\0' <repeats 60 times>, "p‡ø_ˇ\000\000∏\021ÄtG:7Û¿à\a\000\001\000\000\000\000\000\000\000\002\000\000\000debug: E€\a\000\000\000\000\000\000lfiø_ˇ\000\000†)¯pˇ", '\0' <repeats 70 times>, "\003", '\0' <repeats 35 times>, "\030<ƒ_ˇ\000\000\030<ƒ_ˇ\000\000Ëfiø_ˇ\000\000Ëfiø_ˇ\000\000«\021<\000\001\000\000\000`›ø_ˇ\000\0001Ò¿_ˇ\000\000\000\000\000\000ˇ\000\000fi`\f\000\001", '\0' <repeats 11 times>, "\030<ƒ_ˇ"...
0000003 0x000000010001e6ab in enc_check_password (plaintext=0x7fff5fbfe496 "testtest", password=0x1005f7688 "C/m2\a#9\005´óÍxÂ@Û\022") at encrypt.c:98
No locals.
0000004 0x00000001003bf556 in do_identify (u=0x1005f7280) at ns_identify.c:98
    pass = 0x7fff5fbfe496 "testtest"
    na = (NickAlias *) 0x1005f7720
    nr = (NickRequest *) 0x1005fc0a0
    res = 1
    tsbuf = "ê‚ø_ˇ\000\000‰\037\003\000\001\000\000"
    modes = "\000\000\000\000\000\000\000\000\000\000P\000\001\000\000\000\001\000?\000\001\000\000\000‡\b\n\000\001", '\0' <repeats 15 times>, "…\001\000\000¿‡ø_ˇ\000\000˛Ê\001\000\001\000\000\000¿‡ø_ˇ\000\000¸\f?\000\001", '\0' <repeats 19 times>, " ·ø_ˇ\000\000∏Ó\001\000\001\000\000\000\000·ø_ˇ\000\000\000\000\000\000\000\000\000\000 ·ø_ˇ\000\000\000\000P\000\001\000\000\000 ·ø_ˇ\000\000–x_\000\001", '\0' <repeats 35 times>, "@‚ø_ˇ\000\0000È\001\000\001\000\000\000íÁ\001\000\001\000\000\000ê·ø_ˇ\000\000`·ø_\001\000\000\000¸\f?\000\001\000\000"...
    len = 6291072
0000005 0x000000010001a134 in do_run_cmd (service=0x1004007f0 "NickServ", u=0x1005f7280, c=0x1005301b0, cmd=0x7fff5fbfe493 "id") at commands.c:102
    mod_current_module_name_save = 0x0
    mod_current_module_save = (Module *) 0x0
    retVal = 0
    current = (Command *) 0x10041aa90
0000006 0x000000010001a027 in mod_run_cmd (service=0x1004007f0 "NickServ", u=0x1005f7280, cmdTable=0x1000aaee0, cmd=0x7fff5fbfe493 "id") at commands.c:71
    c = (Command *) 0x1005301b0
0000007 0x000000010003979d in nickserv (u=0x1005f7280, buf=0x7fff5fbfe493 "id") at nickserv.c:260
    cmd = 0x7fff5fbfe493 "id"
    s = 0x0
0000008 0x000000010002d2f0 in m_privmsg (source=0x1005f7290 "DukeP2", receiver=0x1005ed960 "NickServ", msg=0x7fff5fbfe493 "id") at messages.c:208
    s = 0x0
    target = 0x1005ed950 ""
    starttime = 1297469191
    stoptime = 4301183312
    bi = (BotInfo *) 0x10004ee3d
    ci = (ChannelInfo *) 0x7fff5fbfe3d0
    u = (User *) 0x1005f7280
0000009 0x0000000100394d9e in anope_event_privmsg (source=0x7fff5fbff4c0 "971AAAAAA", ac=2, av=0x1005f7420) at inspircd20.c:1868
    ud = (Uid *) 0x1005ed950
    u = (User *) 0x1005f7280
0000010 0x0000000100045bde in process () at process.c:398
    retVal = 0
    current = (Message *) 0x0
    source = "971AAAAAA\000\000\000\n\000\000\000\020ıø_ˇ\000\000Ì“\004\000\001\000\000\000\020ıø_ˇ\000\000†I\n\000\001\000\000\000\005\000\000\000\000\004\000\000†I\n\000\001\000\000"
    cmd = "PRIVMSG", '\0' <repeats 41 times>, "\005", '\0' <repeats 11 times>, "G:7Û"
    buf = "PRIVMSG\0003AXAAAAAC\000:id\000testtest\000d testtest\000\000rolator@anope.org\000@anope.org\000\000ST=Germany,CN=DukePyrolator,EMAIL=DukePyrolator@anope.org\000.org\000\000\000\000:DukePyrolator\000ator\000\000ENGE\000{ym`X}sngoe?YRZEiMYf\000PREFIX\000(qaohv)"...
    s = 0x7fff5fbfe488 "3AXAAAAAC"
    ac = 2
    av = (char **) 0x1005f7420
    m = (Message *) 0x100401ff0
0000011 0x000000010002b454 in main (ac=3, av=0x7fff5fbff5c0, envp=0x7fff5fbff5e0) at main.c:667
    t = 1297469189
    last_update = 1297469158
    last_expire = 1297469158
    last_check = 1297469189
    last_DefCon = 1297469158
    i = 674208
    progname = 0x7fff5fbff73b "services"

(0005737)
katsklaw (reporter)
2011-01-30 01:17

That's not really a solution as both enc types should work.
(0005733)
Alex (reporter)
2011-01-25 20:33
edited on: 2011-01-25 20:33

Solution: used enc_sha1 instead of enc_md5

(0005732)
Alex (reporter)
2011-01-25 20:06

Here is the backtrace: http://pastebin.com/3eJ7RrVF [^]

- Issue History
Date Modified Username Field Change
2011-01-25 18:27 Alex New Issue
2011-01-25 20:06 Alex Note Added: 0005732
2011-01-25 20:33 Alex Note Added: 0005733
2011-01-25 20:33 Alex Note Edited: 0005733 View Revisions
2011-01-30 01:17 katsklaw Note Added: 0005737
2011-02-13 16:33 alexbarton Note Added: 0005745
2011-02-13 16:34 alexbarton Note Edited: 0005745 View Revisions
2011-02-13 16:35 alexbarton Note Edited: 0005745 View Revisions
2011-04-06 13:01 DanClarkePro Note Added: 0005784
2011-04-06 21:34 Adam Note Added: 0005786
2011-04-06 21:34 Adam Status new => feedback
2011-04-23 08:32 chaz Note Added: 0005800
2011-04-23 08:32 chaz Status feedback => closed
2011-04-23 08:32 chaz Assigned To => chaz
2011-04-23 08:32 chaz Resolution open => unable to reproduce
2011-04-23 20:05 chaz Note Added: 0005803
2011-04-23 20:05 chaz Status closed => acknowledged
2011-04-27 04:28 Adam Note Added: 0005804
2011-04-29 14:09 chaz Note Added: 0005821
2011-05-02 19:20 Adam Note Added: 0005822
2011-05-02 19:20 Adam Status acknowledged => resolved
2011-05-02 19:20 Adam Assigned To chaz => Adam


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker