View Issue Details

IDProjectCategoryView StatusLast Update
0001220Anope Development (1.9.x series)Modules Systempublic2010-12-27 08:04
ReporterCereaL Assigned ToAdam  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebian 
Summary0001220: MemoServ and HostServ are losing data when services shutdown - using m_mysql
DescriptionRe HostServ:
It appears that the only data being written into table anope_hs_core is the vhosts which have been manually set. Anything which the user has requested and has been activated isnt appearing.

This has been tested by having a user request a vhost, having it confirmed, then checking the table for that users name. It doesnt appear!

However, if its manually set using /hostserv set user vhost it appears

Re MemoServ:
It appears that any messages which have been read and deleted are only temporary while the services are online. If they are shutdown either via a crash or /operserv shutdown .. the and messages havent been removed.

looking at the sql databases is a lil harder with these ones because it says the following: [BLOB - 53 B] so unaware of what the messages are actually about.
Steps To ReproduceAs per above
TagsNo tags attached.

Activities

Adam

2010-12-27 08:04

administrator   ~0005706

Fixed in 49dd1c34096623e916f6e5aba44f7036738c3344

CereaL

2010-12-26 20:50

reporter   ~0005705

Might I add onto this .. OperServ is losing any exceptions that have been created

[04:19] <CereaL> exception view
[04:19] <OperServ> Current Session Limit Exception list:
[04:19] <OperServ> 1. monitor.austirc.net (by CereaL on Dec 27 04:19:45 2010 EST (6 seconds ago); expires in 1 day)
[04:19] <OperServ> Limit: 10 - services

since the crash
[05:48] <CereaL> exception view
[05:48] <OperServ> No matching entries on session-limit exception list.

Issue History

Date Modified Username Field Change
2010-12-26 20:35 CereaL New Issue
2010-12-26 20:50 CereaL Note Added: 0005705
2010-12-27 08:04 Adam Note Added: 0005706
2010-12-27 08:04 Adam Status new => resolved
2010-12-27 08:04 Adam Resolution open => fixed
2010-12-27 08:04 Adam Assigned To => Adam