Anope Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001203Anope Development (1.9.x series)Otherpublic2010-11-15 18:232011-03-23 05:59
Reporternenolod 
Assigned ToAdam 
PrioritynormalSeverityminorReproducibilityN/A
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001203: anope "xmlrpc" doesn't support http transport (which is mandated by the xmlrpc specification)
Descriptionhi,

your "xmlrpc" implementation is not actually an "xmlrpc" implementation.

xmlrpc is explicitly delivered via HTTP messages, while your implementation writes raw xmlrpc packets directly onto a socket.

thusly, i believe it should be renamed or HTTP support should be added so that anope's "xmlrpc" is compatible with xmlrpc libraries, such as pyxmlrpc.

the xmlrpc specification, located at http://www.xmlrpc.com/spec [^] explicitly defines xmlrpc requests as HTTP-POST messages:

> An XML-RPC message is an HTTP-POST request.
> The body of the request is in XML.
> A procedure executes on the server and the value it returns is also formatted in XML.

thusly, anope "xmlrpc" should support HTTP-POST or be renamed to "anoperpc" to alleviate confusion with actual standards supported by thousands of applications.

furthermore, anope's xmlrpc calls lack appropriate namespacing. while the XMLRPC specification allows this, it is generally accepted practice to namespace your methodNames, e.g. anope.login, anope.command, and so on.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005658)
chaz (administrator)
2010-11-15 22:36

No.

I marked it as suspended for another time since Mantis doesn't seem to have a LATER like Bugzilla does.

There is nothing about burying it otherwise I would just have deleted it and not bothered any further.
(0005657)
nenolod (reporter)
2010-11-15 22:30

Seems more like you're attempting to bury this under the rug to me. Reopening.
(0005655)
chaz (administrator)
2010-11-15 21:38

Taken on board, thank you.

- Issue History
Date Modified Username Field Change
2010-11-15 18:23 nenolod New Issue
2010-11-15 21:38 chaz Note Added: 0005655
2010-11-15 21:39 chaz Status new => closed
2010-11-15 21:39 chaz Assigned To => chaz
2010-11-15 21:39 chaz Resolution open => suspended
2010-11-15 22:30 nenolod Note Added: 0005657
2010-11-15 22:30 nenolod Status closed => feedback
2010-11-15 22:30 nenolod Resolution suspended => reopened
2010-11-15 22:36 chaz Note Added: 0005658
2011-03-23 05:59 Adam Assigned To chaz => Adam
2011-03-23 05:59 Adam Severity major => minor
2011-03-23 05:59 Adam Status feedback => resolved
2011-03-23 05:59 Adam Resolution reopened => fixed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker