Anope Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001180Anope Stable (1.8.x series)BotServpublic2010-08-06 02:022010-09-12 09:52
ReporterCyberBotX 
Assigned ToCyberBotX 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformamd64OSFreeBSDOS Version8.0-RELEASE-p2
Product Version1.8.4 
Target Version1.8.4Fixed in VersionGIT (include a /version response in report) 
Summary0001180: InspIRCd 1.2 causes BotServ messages in a channel to come from Anope server name instead of bot's nick after bot's nick changed
DescriptionThe following is a debug log of what occured:

[Aug 05 17:51:49 2010] OperServ: CyberBotX: set debug on
[Aug 05 17:51:49.840991 2010] Debug mode activated
[Aug 05 17:51:49.841253 2010] debug: Sent: :00AAAAAAB NOTICE 379AAAAAL :Services are now in debug mode.
[Aug 05 17:52:02.584656 2010] debug: Received: :379AAAAAL PRIVMSG 00AAAAAAG :bot change CthulhuLavos Lavos
[Aug 05 17:52:02.585064 2010] debug: Sent: :00A DELLINE Q CthulhuLavos
[Aug 05 17:52:02.586071 2010] debug: Sent: :00AAAAAAM NICK Lavos 1281055922
[Aug 05 17:52:02.586116 2010] debug: Sent: :00A ADDLINE Q Lavos OperServ 1281055922 0 :Reserved for services
[Aug 05 17:52:02.586151 2010] debug: Sent: :00AAAAAAG NOTICE 379AAAAAL :Bot ^BCthulhuLavos^B has been changed to Lavos!lavos@world_devourer.heavenlyplace.net (Lavos *skree*)
[Aug 05 17:52:02.586169 2010] debug: Emitting event "bot_change" (1 args)
[Aug 05 17:52:02.586234 2010] debug: Received: :379 DELLINE Q CthulhuLavos
[Aug 05 17:52:12.821434 2010] debug: Received: :379AAAAAL PRIVMSG 00AAAAAAG :say #Crim SKREE!
[Aug 05 17:52:12.821958 2010] debug: Sent: :00A PRIVMSG #CRIM :SKREE!
[Aug 05 17:52:15.825387 2010] debug: Received: :379 PING 379 00A
[Aug 05 17:52:15.825680 2010] debug: Sent: :00A PONG 00A 379
[Aug 05 17:52:17.511920 2010] debug: Received: :379AAAAAL PRIVMSG 00AAAAAAG :bot change Lavos CthulhuLavos
[Aug 05 17:52:17.513837 2010] debug: Sent: :00A DELLINE Q Lavos
[Aug 05 17:52:17.513923 2010] debug: Sent: :00AAAAAAM NICK CthulhuLavos 1281055937
[Aug 05 17:52:17.513954 2010] debug: Sent: :00A ADDLINE Q CthulhuLavos OperServ 1281055937 0 :Reserved for services
[Aug 05 17:52:17.513987 2010] debug: Sent: :00AAAAAAG NOTICE 379AAAAAL :Bot ^BLavos^B has been changed to CthulhuLavos!lavos@world_devourer.heavenlyplace.net (Lavos *skree*)
[Aug 05 17:52:17.514004 2010] debug: Emitting event "bot_change" (1 args)
[Aug 05 17:52:17.514060 2010] debug: Received: :379 DELLINE Q Lavos
[Aug 05 17:52:20.012396 2010] debug: Received: :379AAAAAL PRIVMSG 00AAAAAAG :say #Crim SKREE!
[Aug 05 17:52:20.012853 2010] debug: Sent: :00AAAAAAM PRIVMSG #CRIM :SKREE!
[Aug 05 17:52:31.837116 2010] debug: Received: :379AAAAAL PRIVMSG 00AAAAAAB :set debug off
[Aug 05 17:52:31.837189 2010] OperServ: CyberBotX: set debug off
[Aug 05 17:52:31.837209 2010] Debug mode deactivated

Resulting in:

[08/05/2010 20:52:02 -5] * CthulhuLavos is now known as Lavos
[08/05/2010 20:52:12 -5] <services.heavenlyplace.net> SKREE!
[08/05/2010 20:52:17 -5] * Lavos is now known as CthulhuLavos
[08/05/2010 20:52:20 -5] <&CthulhuLavos> SKREE!

The key seems to be that the first BS SAY comes from 00A instead of 00AAAAAAM like it should've been.

I believe the problem to be with inspircd_cmd_privmsg within inspircd12.c, but I am unsure as I don't touch 1.8.x's code if I don't have to. :P
Steps To ReproduceUse InspIRCd 1.2, make sure a bot is assigned to a channel and it speaks when you use BS SAY, use BS BOT CHANGE to change the bot's nick, do BS SAY again.
Additional InformationBots that were already connected seem to be unaffected, and changing back to the bot's original nick allows it to work again.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005477)
chaz (administrator)
2010-09-12 09:52

Issues marked as resolved for a period of time without argument will be closed.
(0005459)
Adam (administrator)
2010-08-06 04:21

Fixed in commit 94f7962e1abc12db7dd4adabcd35c067ad17889e

- Issue History
Date Modified Username Field Change
2010-08-06 02:02 CyberBotX New Issue
2010-08-06 02:02 CyberBotX Assigned To => CyberBotX
2010-08-06 02:02 CyberBotX Status new => acknowledged
2010-08-06 04:21 Adam Note Added: 0005459
2010-08-06 04:21 Adam Status acknowledged => resolved
2010-08-06 04:21 Adam Fixed in Version => SVN (include a /version response in report)
2010-08-06 04:21 Adam Resolution open => fixed
2010-09-12 09:52 chaz Note Added: 0005477
2010-09-12 09:52 chaz Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker