Anope Bug Tracker - Anope Stable (2.0.x series)
View Issue Details
0001719Anope Stable (2.0.x series)[All Projects] Generalpublic2018-12-21 20:462018-12-21 20:46
daemhan 
 
normalmajoralways
newopen 
Ubuntu16.04.5 LTS
0001719: sql_live not reflecting database updates/new entries client-side
Module: sql_live
SQL: sqlite
Anope Version: 2.0.5

Conf annotations state: "This module reads and writes to SQL in real time. Changes to the SQL tables will be immediately reflected into Anope."

I am finding that this is not the case. Changes or insertions to the NickCore table are not reflecting services-side when requesting information client-side.
Used:
UPDATE
INSERT INTO

UPDATE successfully changes any given value in the database, but it is not reflected when calling /ns info via IRC client.
* tried updating email on previously registered nickname
* tried changing display name on previously registered nickname

INSERT INTO the NickCore table successfully inserts values for new nicknames, but issuing /ns info [nickname] returns [nickname] is not registered. Example:
sqlite> select * from anope_db_NickCore where display = 'testnick01';
18251|2018-12-21 00:14:40|1|1|1|1|1|1|1||testnick01|tester@redacted.email||20|bcrypt:$2a$10$hashpass|1|||||||1||||||

* -NickServ- Nick testnick01 isn't registered.
No tags attached.
Issue History
2018-12-21 20:46daemhanNew Issue

There are no notes attached to this issue.